You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

67 lines
3.1KB

  1. source ENV['GEM_SOURCE'] || "https://rubygems.org"
  2. def location_for(place, fake_version = nil)
  3. if place =~ /^(git[:@][^#]*)#(.*)/
  4. [fake_version, { :git => $1, :branch => $2, :require => false }].compact
  5. elsif place =~ /^file:\/\/(.*)/
  6. ['>= 0', { :path => File.expand_path($1), :require => false }]
  7. else
  8. [place, { :require => false }]
  9. end
  10. end
  11. group :test do
  12. gem 'puppetlabs_spec_helper', '~> 1.2.2', :require => false
  13. gem 'rspec-puppet', '~> 2.5', :require => false
  14. gem 'rspec-puppet-facts', :require => false
  15. gem 'rspec-puppet-utils', :require => false
  16. gem 'puppet-lint-absolute_classname-check', :require => false
  17. gem 'puppet-lint-leading_zero-check', :require => false
  18. gem 'puppet-lint-trailing_comma-check', :require => false
  19. gem 'puppet-lint-version_comparison-check', :require => false
  20. gem 'puppet-lint-classes_and_types_beginning_with_digits-check', :require => false
  21. gem 'puppet-lint-unquoted_string-check', :require => false
  22. gem 'puppet-lint-variable_contains_upcase', :require => false
  23. gem 'metadata-json-lint', :require => false
  24. gem 'puppet-blacksmith', :require => false
  25. gem 'voxpupuli-release', :require => false, :git => 'https://github.com/voxpupuli/voxpupuli-release-gem.git'
  26. gem 'puppet-strings', '~> 0.99.0', :require => false
  27. gem 'rubocop-rspec', '~> 1.6', :require => false if RUBY_VERSION >= '2.3.0'
  28. gem 'json_pure', '<= 2.0.1', :require => false if RUBY_VERSION < '2.0.0'
  29. gem 'mocha', '>= 1.2.1', :require => false
  30. gem 'coveralls', :require => false if RUBY_VERSION >= '2.0.0'
  31. gem 'simplecov-console', :require => false if RUBY_VERSION >= '2.0.0'
  32. end
  33. group :development do
  34. gem 'travis', :require => false
  35. gem 'travis-lint', :require => false
  36. gem 'guard-rake', :require => false
  37. end
  38. group :system_tests do
  39. if beaker_version = ENV['BEAKER_VERSION']
  40. gem 'beaker', *location_for(beaker_version)
  41. end
  42. if beaker_rspec_version = ENV['BEAKER_RSPEC_VERSION']
  43. gem 'beaker-rspec', *location_for(beaker_rspec_version)
  44. else
  45. gem 'beaker-rspec', :require => false
  46. end
  47. gem 'serverspec', :require => false
  48. gem 'beaker-puppet_install_helper', :require => false
  49. end
  50. if facterversion = ENV['FACTER_GEM_VERSION']
  51. gem 'facter', facterversion.to_s, :require => false, :groups => [:test]
  52. else
  53. gem 'facter', :require => false, :groups => [:test]
  54. end
  55. ENV['PUPPET_VERSION'].nil? ? puppetversion = '~> 4.0' : puppetversion = ENV['PUPPET_VERSION'].to_s
  56. gem 'puppet', puppetversion, :require => false, :groups => [:test]
  57. # vim: syntax=ruby